Profile visits blocks
Incident Report for Viadeo
Resolved
issue has been fixed
Posted 3 months ago. Mar 22, 2017 - 19:02 CET
Investigating
Profile visits blocks are not displayed. Engineering team is investigating.
Posted 3 months ago. Mar 22, 2017 - 17:41 CET